Werk #4556

KomponenteAgent Bakery
TitelFixed compatibility problem in agent updater with some older windows versions
Datum2017-03-23 09:42:02
Check_MK EditionCheck_MK Enterprise Edition (CEE)
Check_MK Version1.4.0b5,1.5.0i1,1.2.8p19
Level1 - Triviale Änderung
KlasseBug Fix
KompatibilitätCompatible - no manual interaction needed

When running Check_MK agent updater under some older Windows versions (eg. Windows XP), a problem with some missing runtime libraries can possibly occur. This would result in an error message beginning with "Error loading Python DLL:..."

A quick-fix for this problem would be the installation of a Microsoft Visual C++ Redistributable package. It can be found at Microsoft support homepage. (support.microsoft.com) with the search term "vcredist_x86". The MS VC++ 2008 Redistributable Package (x86) would be sufficient.

However, the needed runtime libraries will be included in all Check_MK releases containg this werk.