Werk #5266

KomponenteAgent Bakery
Titelcmk-update-agent: Python 2.4 compatibility fix
Datum2017-12-15 12:31:38
Check_MK EditionCheck_MK Enterprise Edition (CEE)
Check_MK Version1.4.0p22
Level1 - Triviale Änderung
KlasseBug Fix
KompatibilitätCompatible - no manual interaction needed

Due to a code statement that is not supported in Python 2.4, the Agent Updater could crash when running on a system with a Python interpreter 2.4 or older.

An execution of cmk-update-agent would crash with an error message like:


File "cmk-update-agent", line 694

with open(get_all_certs_filepath(), "w") as acf:

^

SyntaxError: invalid syntax