Werk #5875

KomponenteWATO
TitelGit: Fixed error "git add --all ... is outside repository" with older git versions
Datum2018-03-02 13:30:14
Check_MK EditionCheck_MK Raw Edition (CRE)
Check_MK Version1.4.0p27,1.5.0b1
Level1 - Trivial Change
KlasseBug Fix
KompatibilitätKompatibel- benötigt keine manuelles eingreifen

When using older git versions (saw this with 1.7.1) an error could occur when enabling the git integration of WATO. This was caused by an incompatibility with the "git add" command used by WATO. It used absolute paths to add the new files that should be added to git instead of relative paths to the current working directory.

This issue was present in all 1.4.0 releases.